<!DOCTYPE html>
<html lang='en'>
<head>
<title>State Sen. Mayne shows city elected officials the new $4.1 billion SLC airport   | Taylorsville Journal</title>
<meta charset='utf-8'>
<meta content='LocablePublisherNetwork.com' name='generator'>
<meta content='width=device-width, initial-scale=1' name='viewport'>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","errorBeacon":"bam-cell.nr-data.net","licenseKey":"cc2c1fbc9a","applicationID":"18721","transactionName":"IQwNRUJXWQhdEBdZRxYKAF1VSxoXUA1P","queueTime":5,"applicationTime":1239,"agent":""}</script>
<script>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</script>
<meta content='122882951100578' property='fb:app_id'>
<meta property="og:title" content="State Sen. Mayne shows city elected officials the new $4.1 billion SLC airport   | Taylorsville Journal" /><meta name="description" content="Taylorsville elected officials recently received an up close and personal look at the new Salt Lake City International Airport, courtesy of State Sen. Karen Mayne." /><meta property="og:description" content="Taylorsville elected officials recently received an up close and personal look at the new Salt Lake City International Airport, courtesy of State Sen. Karen Mayne." /><meta property="og:type" content="article" /><meta property="og:image" content="http://locable-assets-production.s3.amazonaws.com/uploads/resource/file/821619/Airport_20tour_202.jpg?timestamp=1620668924" /><meta property="og:image:width" content="3810" /><meta property="og:image:height" content="1969" /><link rel="canonical" href="https://www.taylorsvillecityjournal.com/2021/05/10/356073/state-sen-mayne-shows-city-elected-officials-the-new-4-1-billion-slc-airport" /><meta property="og:url" content="http://www.taylorsvillecityjournal.com/2021/05/10/356073/state-sen-mayne-shows-city-elected-officials-the-new-4-1-billion-slc-airport" /><meta name="keywords" content="Today, News, May 2021" /><meta name="ICMB" content="" />
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="gizMUwdbz+5YXoqNNK+DwRXe8vu3zLCDwSvRM8RShy/5BJgQM+KgSm0kl6GFDXgUMroQBCenUYN23vlC32U9Zg==" />
<link rel="shortcut icon" type="image/x-icon" href="//cdn0.locable.com/uploads/favicon_img/file/42/CJ_Favicon-32x32.png" />
<link rel="stylesheet" media="screen" href="//cdn2.locable.com/assets/application-d67e4f2949370a46eb7661b48d00cda5723a2291958132c42acfead07ecb23de.css" />
<link rel="stylesheet" media="print" href="//cdn3.locable.com/assets/print-fe1b40859b2ebf3b0a55c395ad974b40f3dc0afb58a59f937c6ab67b342c3f65.css" />
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
</script>
<script>
  ga('create', 'UA-62913511-1', 'auto');
  ga('send', 'pageview');
</script>
<script>
  ga('create', 'UA-16494411-5', 'auto', {'name': 'rollup'});
  ga('rollup.send', 'pageview');
</script>
<style>
  .custom-header, .custom-header a {color: #ffffff !important; }.custom-header {background-color: #1b4077 !important; }.custom-header {text-align: center !important; }#main-nav .navbar-nav .nav-link, .classic-nav .navbar-brand .navbar-text, #main-nav .navbar-toggler span {color:  !important;} #main-nav .navbar-toggler {border-color:  !important;}#main-nav .navbar-nav .nav-link:hover, .classic-nav .navbar-brand:hover .navbar-text {color: #cbb677 !important;}#main-nav .navbar-nav .nav-link:hover, .classic-nav .navbar-brand:hover .navbar-text {background-color: #1b4077 !important;}.public #main-nav .container, .dco #main-nav .container, .admin #main-nav, .admin #main-nav .container {background-color:  !important;}#main-nav .dropdown-item {color:  !important;}#main-nav .dropdown-item:hover {color:  !important;}#main-nav .dropdown-item:hover {background-color:  !important;}#main-nav .dropdown-menu {background-color:  !important;}#secondary-nav .navbar-nav .nav-link, #secondary-nav a {color: #ffffff !important;}#secondary-nav .navbar-nav .nav-link:hover, #secondary-nav a:hover {color: #1b4077 !important;}#secondary-nav .navbar-nav .nav-link:hover, #seconary-nav a:hover {background-color: #cbb677 !important;}#secondary-nav nav {background-color: #1b4077 !important;}#secondary-nav .navbar-nav .dropdown-menu .nav-link {color:  !important;}#secondary-nav .navbar-nav .dropdown-menu .nav-link:hover {color:  !important;}#secondary-nav .navbar-nav .dropdown-menu .nav-link:hover {background-color:  !important;}#secondary-nav .dropdown-menu {background-color:  !important;}#secondary-nav .navbar-nav .nav-link, #secondary-nav a {font-size: 1.2rem !important; line-height: 1.2rem; letter-spacing: 1.5px;}.col-menu li a, .simple-footer li a, #copyright p.text-muted a {color:  !important; }.col-menu li a:hover, .simple-footer li a:hover, #copyright p.text-muted a:hover {color: #1b4077 !important; }#footer p, #footer h6, #copyright p {color:  !important; }.places #copyright, .places #footer, #copyright .container, #footer .container {background-color:  !important; }
</style>
<style>
  
</style>
<meta name="google-site-verification" content="qzXgywgOkaMgeBvUTT0hJx0Wtq3ZLucK8uFD7fTB8q4" />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script async='' defer='defer' src='https://addevent.com/libs/atc/1.6.1/atc.min.js' type='text/javascript'></script>
</head>
<body class='classic-header public'>
<a class="sr-only" href="#content">Skip to main content</a>
<div class='fixed-top' data-toggle='affix'>
<section id='main-nav'>
<div class='container theme-shadow bg-white'>
<nav class='classic-nav navbar navbar-expand-lg navbar-light'>
<a class="navbar-brand" href="/"><span class='navbar-text fas fa-home' style='position:relative;top:2px'></span>
</a><button aria-controls='navbarContent' aria-expanded='false' aria-label='Toggle navigation' class='navbar-toggler' data-target='#navbarContent' data-toggle='collapse' type='button'>
<span class='fas fa-bars'></span>
</button>
<div class='collapse navbar-collapse' id='navbarContent'>
<ul class='navbar-nav mr-lg-auto' style='white-space: nowrap;'>
<li class='nav-item page-60526-nav'><a class="nav-link" href="/pages/aboutus">About Us</a></li>

<li class='nav-item page-60534-nav'><a class="nav-link" href="/pages/advertise">Advertise</a></li>

<li class='nav-item page-52022-nav'><a class="nav-link" href="/pages/digitalissues">E-Edition</a></li>

<li class='nav-item page-92572-nav'><a class="nav-link" href="/pages/rack-locations">Rack Locations</a></li>

<li class='nav-item page-114341-nav'><a class="nav-link" href="/pages/more-journals">More Journals</a></li>

<li class='nav-item page-60548-nav'><a class="nav-link" href="/pages/contactus">Contact Us</a></li>

<li class='nav-item page-345209-nav'><a class="nav-link" href="/pages/write-for-us">Write For Us</a></li>

<div class='dropdown-divider d-inline d-lg-none'></div>
<div class='d-lg-none'>
<li class='category-134-nav nav-item theme-menu-toggle' data-toggle='category-134'>

<a class="nav-link" href="/categories/news">News
<b class='caret'></b>
</a></li>
<li class='category-425-nav nav-item theme-menu-toggle' data-toggle='category-425'>

<a class="nav-link" href="/categories/sports">Sports
<b class='caret'></b>
</a></li>
<li class='category-636-nav nav-item theme-menu-toggle' data-toggle='category-636'>

<a class="nav-link" href="/categories/local-life">Local Life
<b class='caret'></b>
</a></li>
<li class='category-423-nav nav-item theme-menu-toggle' data-toggle='category-423'>

<a class="nav-link" href="/categories/education">Education
<b class='caret'></b>
</a></li>
<li class='category-776-nav nav-item theme-menu-toggle' data-toggle='category-776'>

<a class="nav-link" href="/categories/business">Business
<b class='caret'></b>
</a></li>
<li class='category-104-nav nav-item theme-menu-toggle' data-toggle='category-104'>

<a class="nav-link" href="/categories/food-dining">Food+Dining
<b class='caret'></b>
</a></li>
<li class='category-101-nav nav-item theme-menu-toggle' data-toggle='category-101'>

<a class="nav-link" href="/categories/arts-entertainment">Arts+Entertainment
<b class='caret'></b>
</a></li>
<li class='calendar-nav nav-item theme-menu-toggle' data-toggle='calendar'>

<a class="nav-link" href="/calendar">Calendar
<b class='caret'></b>
</a></li>
<li class='directory-nav nav-item theme-menu-toggle' data-toggle='directory'>

<a class="nav-link" href="/businesses">Directory
<b class='caret'></b>
</a></li>
<div class='dropdown-divider d-inline d-lg-none'></div>
<div class='dropdown-divider'></div>
</div>
<div class='d-lg-none'>

<li class='nav-item'><a class="nav-link px--lg-2 py-lg-0 submit-event-link" href="/events/new">Submit an Event</a></li>
<li class='nav-item'><a class="nav-link px-lg-2 py-lg-0 create-listing-link" href="/places">List Your Business</a></li>
<li class='nav-item'>
<a class="nav-link px-lg-2 py-lg-0" href="/users/sign_in">Login/Join
</a></li>
<div class='dropdown-divider'></div>
</div>
</ul>
<ul class='navbar-nav ml-lg-auto'>
<ul class='list-inline social-links' style='white-space: nowrap;'>
<li class='list-inline-item mr-2'>
<a target="_blank" class="facebook" href="https://www.facebook.com/TKJournal/"><i class='fab fa-facebook fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="instagram" href="https://instagram.com/cityjournals"><i class='fab fa-instagram fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="linkedin" href="https://www.linkedin.com/company/city-journals/"><i class='fab fa-linkedin fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="twitter" href="https://twitter.com/TVilleJournal"><i class='fab fa-twitter fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="email" href="/pages/contactus"><i class='fas fa-envelope fa-2x'></i>
</a></li>
</ul>
<form class="form-inline" action="/search" accept-charset="UTF-8" method="get"><input name="utf8" type="hidden" value="&#x2713;" />
<div class='input-group'>
<label class="sr-only" for="q">Search</label>
<input type="text" name="q" id="q" placeholder="Search Site" class="form-control" />
<span class='input-group-btn'>
<button class='btn btn-secondary btn-search'>
<span class='sr-only'>Search</span>
<span class='fas fa-search'></span>
</button>
</span>
</div>
</form>
</ul>
</div>
</nav>
</div>
</section>
</div>
<section id='alerts'>
<div class='container theme-shadow bg-white'>
<div class='d-flex justify-content-center'>
</div>
</div>
</section>
<header>
<section id='masthead'>
<div class='container theme-shadow bg-white'>
<div class='row'>
<div class='col-12 col-md-5'>
<h1 class='p-3'><a href="/"><img alt="Taylorsville Journal" style="max-width: 100%;" src="//cdn3.locable.com/uploads/logo_image/file/407/CJ-Website_Taylorsville.png" /></a></h1>
</div>
<div class='col-12 col-md-7'>
<div class='py-3'>
<script type="text/javascript">
    var _ss = _ss || [];
    _ss.push(['_setDomain', 'https://koi-3QNIUMYMX0.marketingautomation.services/net']);
    _ss.push(['_setAccount', 'KOI-441KJ55HUQ']);
    _ss.push(['_trackPageView']);
(function() {
    var ss = document.createElement('script');
    ss.type = 'text/javascript'; ss.async = true;
    ss.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'koi-3QNIUMYMX0.marketingautomation.services/client/ss.js?ver=1.1.1';
    var scr = document.getElementsByTagName('script')[0];
    scr.parentNode.insertBefore(ss, scr);
})();
</script></div>
</div>
</div>
</div>
</section>
<div class='d-none d-lg-inline'>
<section id='secondary-nav'>
<div class='container theme-shadow bg-white'>
<div class='row py-1'>
<div class='col-sm-12'>
<nav class='navbar navbar-expand-lg navbar-light'>

<ul class='navbar-nav mr-auto flex-wrap' style='white-space: nowrap;'>






<li class='category-134-nav nav-item theme-menu-toggle' data-toggle='category-134'>

<a class="nav-link" href="/categories/news">News
<b class='caret'></b>
</a></li>
<li class='category-425-nav nav-item theme-menu-toggle' data-toggle='category-425'>

<a class="nav-link" href="/categories/sports">Sports
<b class='caret'></b>
</a></li>
<li class='category-636-nav nav-item theme-menu-toggle' data-toggle='category-636'>

<a class="nav-link" href="/categories/local-life">Local Life
<b class='caret'></b>
</a></li>
<li class='category-423-nav nav-item theme-menu-toggle' data-toggle='category-423'>

<a class="nav-link" href="/categories/education">Education
<b class='caret'></b>
</a></li>
<li class='category-776-nav nav-item theme-menu-toggle' data-toggle='category-776'>

<a class="nav-link" href="/categories/business">Business
<b class='caret'></b>
</a></li>
<li class='category-104-nav nav-item theme-menu-toggle' data-toggle='category-104'>

<a class="nav-link" href="/categories/food-dining">Food+Dining
<b class='caret'></b>
</a></li>
<li class='category-101-nav nav-item theme-menu-toggle' data-toggle='category-101'>

<a class="nav-link" href="/categories/arts-entertainment">Arts+Entertainment
<b class='caret'></b>
</a></li>
<li class='calendar-nav nav-item theme-menu-toggle' data-toggle='calendar'>

<a class="nav-link" href="/calendar">Calendar
<b class='caret'></b>
</a></li>
<li class='directory-nav nav-item theme-menu-toggle' data-toggle='directory'>

<a class="nav-link" href="/businesses">Directory
<b class='caret'></b>
</a></li>
<div class='dropdown-divider d-inline d-lg-none'></div>
</ul>
</nav>
</div>
</div>
</div>
</section>
</div>
<section id='pushdown'>
<div class='container theme-shadow bg-white'>
<div class='d-flex justify-content-center'>
<div class='py-3'><broadstreet-zone zone-id='pushdown' keywords='articles, article_state-sen-mayne-shows-city-elected-officials-the-new-4-1-billion-slc-airport, taylorsville-journal'></broadstreet-zone><broadstreet-zone alt-zone-id='pushdown' keywords='articles, article_state-sen-mayne-shows-city-elected-officials-the-new-4-1-billion-slc-airport, taylorsville-journal'>
</broadstreet-zone></div>
</div>
</div>
</section>
</header>
<div class='container theme-shadow bg-white' id='content'>
<div class='row'>
<div class='col-12 col-lg-8'>
<section id='admin-buttons'>
<div class='container'>
<div class='row'>
<div class='col-12'>
<div class='btn-group btn-group-sm'>
</div>
</div>
</div>
<div class='row py-2'>
<div class='col-12'>
</div>
</div>
</div>
</section>
<article>
<div class='container'>
<div class=''>
<div class='row py-3'>
<div class='col-12'>
<h1 class='py-0'>
State Sen. Mayne shows city elected officials the new $4.1 billion SLC airport
</h1>
<span class='small text-muted'>
May 10, 2021 11:31AM
&#x25CF
By Carl Fauver
</span>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='images-contain'>
<img alt="" class="img-fluid" src="//cdn1.locable.com/uploads/resource/file/821619/fill/800x600/Airport_20tour_202.jpg?timestamp=1620667910" />
</div>
<p class='h6 text-right'>
<small><p>Artwork in this main corridor at the new Salt Lake City International Airport has earned it the name, “The Canyon.” (Meredith Harker)<br></p></small>
</p>
</div>
</div>
<div class='d-flex justify-content-center'>
<div class='py-3 broadstreet'>
<broadstreet-zone zone-id='sponsored' keywords='articles, article_state-sen-mayne-shows-city-elected-officials-the-new-4-1-billion-slc-airport, taylorsville-journal'></broadstreet-zone><broadstreet-zone alt-zone-id='sponsored' keywords='articles, article_state-sen-mayne-shows-city-elected-officials-the-new-4-1-billion-slc-airport, taylorsville-journal'>
</broadstreet-zone>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='clearfix images-contain images-thumbnails'>
<p><span>By Carl Fauver | <a href="/cdn-cgi/l/email-protection#e685c8808793908394a68b9f858f929f8c89939488878a95c885898b"><span class="__cf_email__" data-cfemail="54377a32352122312614392d373d202d3e3b21263a3538277a373b39">[email&#160;protected]</span></a></span></p><p>Taylorsville Mayor Kristie Overson and members of the city council only thought they were touring the biggest and most expensive construction project they would see up close and personal this spring, when they walked through the new $39 million Mid-Valley Performing Arts Center in late March.</p><p>Little did they know, just two weeks later they would visit something a hundred times more expensive—and more than 10 times larger (so far, and still growing)—courtesy of Utah State Sen. Karen Mayne. As a member of the Airport Advisory Board, Mayne arranged for the elected officials in her senate district to tour the new $4.1 billion Salt Lake City International Airport.</p><p>“I am senator over (at least parts of) Taylorsville, West Valley City and Kearns, so, I wanted to make sure elected officials from those cities got to see the new airport,” Mayne said. “Utah is booming, and this is a crown jewel for us to continue to fulfill our financial destiny.”</p><p>About 15 elected officials from the cities of West Valley and Taylorsville, along with the metro township of Kearns, spent more than two hours at the spacious new airport, April 12. Joining Overson from the Taylorsville City Council were Dan Armstrong, Anna Barbieri, Ernest Burgess, Meredith Harker and a couple of their spouses.</p><p>“It was my first time out to the new airport, and it was absolutely amazing,” Harker said. “It’s so big, modern and beautiful. The views of the Wasatch mountains through the huge windows are breathtaking. And it was built with no local or state taxpayer dollars. Just incredible.”</p><p>Indeed, if you speak to anyone affiliated with the new airport, that is the first fact they are anxious to share. Some federal funding has gone into the new Salt Lake City International Airport but nothing directly from Salt Lake or Utah tax revenues. Mayne also touted that impressive fact to state lawmakers during this year’s session in her Senate Joint Resolution 10.</p><p>“S.J.R 10 - Commemorating the New Salt Lake City Airport” reads, in part: </p><ul><li>WHEREAS, the new…airport is the first new hub airport built in the United States in the 21st Century; and</li><li>WHEREAS, no local tax dollars are being spent…</li><li>NOW, THEREFORE, BE IT RESOLVED that the Legislature of the state of Utah commemorates the opening of the first phases…</li></ul><p>Mayne is the only state lawmaker serving on the 11-member Airport Advisory Board. She was originally appointed to a four-year term in January 2017 and just renewed in the post earlier this year.</p><p>“I thought my legislative experience and my work promoting Utah business made me a good candidate [for the board],” she said. “For one thing, I wanted to look out for the interests of Utah workers. They’ve had as many as 1,700 workers a day on site. I wanted to make sure as many local employees and local businesses as possible were being hired.”</p><p>The west ends of Concourses A and B opened last fall. Between the two, they are nearly a million square feet. Now that airport traffic has shifted to those new concourses, the old terminal has been completely demolished and work is continuing on the east ends of the concourses, where the old terminals used to stand.</p><p>City Councilman Dan Armstrong was one of the Taylorsville elected officials who also took is wife on the airport tour.</p><p>“She really liked it, and now she can’t wait until we go somewhere and actually use the airport,” Armstrong said. “It’s pretty grandiose. Such a beautiful building and laid out in a very efficient manner. I have been in a lot of airports, and this one compares with the nicest I have seen. It’s very open and spacious.”</p><p>That’s a primary reason why talk of replacing the old airport began as early as the 1990s, because more space was desperately needed.</p><p>“The original airport was built to accommodate 10 million passengers per year, but we had far exceeded that,” airport spokeswoman Nancy Volmer said. “Before the pandemic hit, we had 27 million passengers through the airport in 2019. In fact, before March 2020, the airport had 70 consecutive months with growth in passenger numbers. The new airport is being built to accommodate 34 million passengers per year.”</p><p>The new terminal also features 50-foot, floor-to-ceiling windows with views of the Wasatch mountains. </p><p>“When we originally surveyed people about what they wanted in the new airport, many said they wanted the beauty of Utah to come through,” Volmer said. “So, designers included the large windows and other prominent artistic features. One main corridor is called ‘The Canyon’ because that’s what it looks like.”</p><p>A new 5-story, 3,600-stall parking garage has also now opened at the Salt Lake City International Airport. And traffic patterns have been shifted going in and out of the airport as well.</p><p>“We advise anyone coming out to download the official ‘SLC International Airport’ app for maps, flight schedules and airport updates,” Volmer said. “It will help you find information regarding gates, restaurants and restrooms. We also suggest people arrive at the airport two hours early. It’s much bigger now and takes longer to get around.”</p><p>Airport officials are proud of a couple of other things. Their literature brags, travelers are never more than 50 yards away from a restroom. Also, they are requiring restaurant operators to not charge any more for their meals at the airport than they do at their other Utah restaurants.</p><p>“I think it’s great they are requiring restaurants to charge their same ‘street’ prices,” Councilwoman Harker added. “No more price gouging.”</p><p>It will now be more than three years until more construction is completed at the airport. By then, airport officials expect pre-coronavirus traveler numbers to be back, making the need for additional space that much more acute. The airport master plan even includes space for a third concourse, although that is believed to be many years down the road.</p><p>The Salt Lake City International Airport is the 23rd busiest in North America and the 85th busiest worldwide. More than 340 flights depart the airport daily to 95 nonstop destinations.</p><p>The First Phase construction now completed features 67 travel gates, 49 elevators, 29 escalators, 18 moving walkways and 7 miles of baggage system conveyor belts.</p>
</div>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='addthis_native_toolbox'></div>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<span class='fas fa-tags' style='margin-right: 2px'></span>
<a style="color: #555" href="/categories/today">Today</a>, <a style="color: #555" href="/categories/news">News</a>
<a style="color: #555" href="/article_tags/may-2021">May 2021</a>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
Follow the Taylorsville Journal on Facebook!
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='fb-comments' data-href='http://www.taylorsvillecityjournal.com/2021/05/10/356073/state-sen-mayne-shows-city-elected-officials-the-new-4-1-billion-slc-airport' data-width='100%'></div>
</div>
</div>
</div>
</div>
</article>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
  var addthis_share = {
     url: "https://www.taylorsvillecityjournal.com/2021/05/10/356073/state-sen-mayne-shows-city-elected-officials-the-new-4-1-billion-slc-airport",
     title: "State Sen. Mayne shows city elected officials the new $4.1 billion SLC airport  ",
     description: "Taylorsville elected officials recently received an up close and personal look at the new Salt Lake City International Airport, courtesy of State Sen. Karen Mayne.",
     media: "//cdn2.locable.com/uploads/resource/file/821619/fill/1200x600/Airport_20tour_202.jpg?timestamp=1620668924"
  }
</script>
</div>
<div class='col-12 col-lg-4'>
<div class='div' style='width: 300px; margin: auto;'>
<div class='undecorate'>
<div class='my-3'>
<h5 class='px-3 py-2 custom-header'>Upcoming Events Near You</h5>
</div>
</div>
<div id='calendar-widget'>
<div class='undecorate'>
<div class='my-3'>
<a class="undecorate" href="/events/198926/banner-fundraiser"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
10
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Banner Fundraiser
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
12:00am
&#183;
The Open Classroom
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/203616/copper-mtn-soccer-fall-registration"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
10
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Copper Mtn Soccer Fall Registration
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
12:00am
&#183;
Virtual Event
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/203847/hometown-complete-a-c-tune-up"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
10
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Hometown Complete A/C Tune-up
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
8:00am
&#183;
Virtual Event
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/198926/banner-fundraiser"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
11
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Banner Fundraiser
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
12:00am
&#183;
The Open Classroom
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/203616/copper-mtn-soccer-fall-registration"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
11
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Copper Mtn Soccer Fall Registration
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
12:00am
&#183;
Virtual Event
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/198926/banner-fundraiser"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
12
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Banner Fundraiser
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
12:00am
&#183;
The Open Classroom
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/203616/copper-mtn-soccer-fall-registration"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
12
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Copper Mtn Soccer Fall Registration
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
12:00am
&#183;
Virtual Event
</div>
</div>
</div>
</div>
</div>
</div>
</a>
<div class='d-flex justify-content-center pb-3'>
<a class="btn btn-light" href="/calendar"><div class='fas fa-calendar-alt'></div>
View All
</a><a class="btn btn-light rounded-0" href="/events/new"><div class='fas fa-plus-circle'></div>
Add Your Event
</a></div>
</div>
</div>
</div>
<div class='images-sidebar my-3 clearfix'>
<div class='py-3 sidebar-current-issue'>
<a style="text-decoration: none" href="/2021/05/04/355551/in-this-issue-may-2021"><div class='row'>
<div class='col-12'>
<h3 class='text-uppercase' style='color:#0a4b94'>
MAY
</h3>
</div>
</div>
<div class='div' style='background-color:#0a4b94; margin: 35px 0 45px;'>
<div class='row'>
<div class='col-6'>
<h4 class='p-3 text-white'>Read It Now</h4>
</div>
<div class='col-6'>
<div class='float-right' style='position:absolute; transform:rotate(4deg); right:20%; top: -30px; box-shadow: 0px 0px 30px rgba(0, 0, 0, 0.5); -webkit-backface-visibility: hidden;'>
<img class="img-fluid" src="//cdn0.locable.com/uploads/resource/file/820478/fit/120x156/Taylorsville_SE_MAY_PRINT_01.jpg?timestamp=1620668924" />
</div>
</div>
</div>
</div>
</a><div class='row'>
<div class='col text-center'>
<small>
<strong>
<div class='text-uppercase'><a style="color: #0a4b94" href="https://www.taylorsvillejournal.com/archives">Archives</a></div>
</strong>
</small>
</div>
<div class='col text-center'>
<small>
<strong>
<div class='text-uppercase'><a style="color: #0a4b94" href="https://issuu.com/mycityjournals/docs/taylorsville_newsletter_se_may_web">Newsletter </a></div>
</strong>
</small>
</div>
</div>
</div>
</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>City Newsletter</h5>
<iframe allowfullscreen="true" style="border:none;width:100%;height:326px;" src="//e.issuu.com/embed.html?d=taylorsville_newsletter_se_may_web&u=mycityjournals"></iframe>
</div>
<div class='images-sidebar my-3 clearfix'>
<div class="image-medium"><a href="https://visitor.r20.constantcontact.com/manage/optin?v=001iTDOE5WqIXkxQh0KtiP6H6B8BbHB4qfswqRgBcay-kHf68Em8lT99NPkA3atW6HRv683TfG2Ys8qhoXT0iulSps1bFNLzqU5AyttHKkL5Ac="><img alt="" src="//cdn3.locable.com/uploads/resource/file/514841/fill/300x0/Newsletter_20Sign_20Up.jpg?timestamp=1551725871"></a></div>
</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>Online Edition</h5>
<iframe allowfullscreen="true" style="border:none;width:100%;height:326px;" src="//e.issuu.com/embed.html?d=taylorsville_se_may_web&u=mycityjournals"></iframe>
</div>
</div>
</div>
</div>
</div>
<footer>
<section id='community-sponsor-footer'>
<div class='container theme-shadow bg-white'>
<div class='row py-3'>
<div class='col-sm-12'>
<h4 class='text-center mb-5'>
BROUGHT TO YOU BY OUR COMMUNITY SPONSORS
</h4>
<div class='community-sponsors-grid'>
<div class='row justify-content-center'>
<div class='col-sm-2 col-6'>
<div class='undecorate'>
<a href="/businesses/ut-salt-lake-city-all-hours-plumbing-2"><img class="img-fluid" src="//cdn0.locable.com/uploads/resource/file/804041/fit/160x100/ah_vertical-logo-color.png?timestamp=1620668924" />
<p class='small text-center text-muted'>All Hours</p>
</a></div>
</div>
<div class='col-sm-2 col-6'>
<div class='undecorate'>
<a href="/businesses/ut-salt-lake-city-diamond-tree-experts-inc"><img class="img-fluid" src="//cdn2.locable.com/uploads/resource/file/804042/fit/160x100/diamond.png?timestamp=1620668924" />
<p class='small text-center text-muted'>DIAMOND TREE EXPERTS INC</p>
</a></div>
</div>
<div class='col-sm-2 col-6'>
<div class='undecorate'>
<a href="/businesses/ut-salt-lake-city-rooter-connectionz"><img class="img-fluid" src="//cdn1.locable.com/uploads/resource/file/804060/fit/160x100/NEW_20LOGO_202019_20MAY-page-001.jpg?timestamp=1620668924" />
<p class='small text-center text-muted'>Rooter Connectionz</p>
</a></div>
</div>
<div class='col-sm-2 col-6'>
<div class='undecorate'>
<a href="/businesses/ut-riverton-larkin-mortuary"><img class="img-fluid" src="//cdn2.locable.com/uploads/resource/file/770550/fit/160x100/larkin.jpg?timestamp=1620668924" />
<p class='small text-center text-muted'>Larkin Mortuary</p>
</a></div>
</div>
<div class='col-sm-2 col-6'>
<div class='undecorate'>
<a href="/businesses/ut-salt-lake-city-action-plumbing"><img class="img-fluid" src="//cdn2.locable.com/uploads/resource/file/804069/fit/160x100/ActionLogo2014.jpg?timestamp=1620668924" />
<p class='small text-center text-muted'>Action Plumbing</p>
</a></div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section id='footer-embed'>
<div class='container theme-shadow bg-white'>
<div class='row py-3'>
<div class='col-sm-12'>
</div>
</div>
</div>
</section>
<section id='footer'>
<div class='container theme-shadow bg-white'>
<div class='row py-3'>
<div class='col-12'>
<nav class='navbar navbar-expand-lg'>
<ul class='navbar-nav mr-auto simple-footer flex-wrap' style='white-space: nowrap;'>
<li class='category-134-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-134'>

<a class="nav-link" href="/categories/news">News
<b class='caret'></b>
</a></li>
<li class='category-425-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-425'>

<a class="nav-link" href="/categories/sports">Sports
<b class='caret'></b>
</a></li>
<li class='category-636-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-636'>

<a class="nav-link" href="/categories/local-life">Local Life
<b class='caret'></b>
</a></li>
<li class='category-423-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-423'>

<a class="nav-link" href="/categories/education">Education
<b class='caret'></b>
</a></li>
<li class='category-776-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-776'>

<a class="nav-link" href="/categories/business">Business
<b class='caret'></b>
</a></li>
<li class='category-104-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-104'>

<a class="nav-link" href="/categories/food-dining">Food+Dining
<b class='caret'></b>
</a></li>
<li class='category-101-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-101'>

<a class="nav-link" href="/categories/arts-entertainment">Arts+Entertainment
<b class='caret'></b>
</a></li>
<li class='calendar-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='calendar'>

<a class="nav-link" href="/calendar">Calendar
<b class='caret'></b>
</a></li>
<li class='d-lg-inline d-none directory-nav nav-item theme-menu-toggle' data-toggle='directory'>

<a class="nav-link" href="/businesses">Directory
<b class='caret'></b>
</a></li>
<div class='dropdown-divider d-inline d-lg-none'></div>
</ul>
</nav>
</div>
</div>
</div>
</section>
<section id='copyright'>
<div class='container theme-shadow'>
<div class='row pt-3' style='padding-bottom: 50px;'>
<div class='col-12'>
<p class='text-muted small p-0 m-0'>
<span class='far fa-copyright'></span>
2021 | Powered by
<a target="_blank" class="text-muted" href="https://www.locablepublishernetwork.com?utm_source=attribution&amp;utm_medium=footer_credits&amp;utm_campaign=taylorsville-journal">Locable</a>
|
<a target="_blank" class="text-muted" href="https://www.locablepublishernetwork.com/terms-of-use/">Terms of Service</a>
</p>
</div>
</div>
</div>
</section>
<section class='fixed-bottom' id='admin-bar'>
<nav>
<div class='d-none d-lg-flex'>
<div class='container'>
<ul class='nav justify-content-center px-3 mx-auto'>

<li class='nav-item'><a class="nav-link px--lg-2 py-lg-0 submit-event-link" href="/events/new">Submit an Event</a></li>
<li class='nav-item'><a class="nav-link px-lg-2 py-lg-0 create-listing-link" href="/places">List Your Business</a></li>
<li class='nav-item'>
<a class="nav-link px-lg-2 py-lg-0" href="/users/sign_in">Login/Join
</a></li>
</ul>
</div>
</div>
</nav>
</section>
</footer>
<div class='modal fade' id='welcome-modal' role='dialog' tabindex='-1'>
<div class='modal-dialog modal-lg' role='document'>
<div class='modal-content'></div>
</div>
</div>
<broadstreet-zone zone-id='popout' keywords='articles, article_state-sen-mayne-shows-city-elected-officials-the-new-4-1-billion-slc-airport, taylorsville-journal'></broadstreet-zone><broadstreet-zone alt-zone-id='popout' keywords='articles, article_state-sen-mayne-shows-city-elected-officials-the-new-4-1-billion-slc-airport, taylorsville-journal'>
</broadstreet-zone>
<script src="//cdn0.locable.com/assets/application-27d8af1507aa4c92997b4312bdb725a3a24374d92f9de61d2a98a1fdc1f66d2b.js"></script>
<script>
  window.s3DirectPostUrl = "https://locable-processing.s3.amazonaws.com/";
  window.s3DirectPostFields = {"AWSAccessKeyId":"AKIAJ6MRUF66HJSZBEVA","key":"uploads/614de097-7439-4931-9df8-8b753dc3f659/${filename}","policy":"eyJleHBpcmF0aW9uIjoiMjAyMS0wNS0xMFQxODo0ODo0NFoiLCJjb25kaXRpb25zIjpbeyJidWNrZXQiOiJsb2NhYmxlLXByb2Nlc3NpbmcifSxbInN0YXJ0cy13aXRoIiwiJGtleSIsInVwbG9hZHMvNjE0ZGUwOTctNzQzOS00OTMxLTlkZjgtOGI3NTNkYzNmNjU5LyJdLHsic3VjY2Vzc19hY3Rpb25fc3RhdHVzIjoiMjAxIn0seyJhY2wiOiJwdWJsaWMtcmVhZCJ9XX0=","signature":"p91T4sMAH5niE/Cjta7CIK/8xQA=","success_action_status":"201","acl":"public-read"};
</script>
<script src="https://static.locablepublishernetwork.com/init-2.min.js" async="async"></script>
<script>
  window.broadstreet = window.broadstreet || { run: [] };
  window.broadstreet.run.push(function() {
    broadstreet.watch( {
      "autoAttach": {},
      "autoAttachAndWatch": {},
      "keywords": ["articles", "article_state-sen-mayne-shows-city-elected-officials-the-new-4-1-billion-slc-airport", "taylorsville-journal"],
      "networkId": "2402",
      "selector": 'broadstreet-zone',
      "softKeywords": true,
      "uriKeywords": false,
      "useZoneAliases": true,
      "useAltZone": 768,
      "domain": "sponsors.locablepublishernetwork.com"
    });
  });
</script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/jQuery.print/1.5.1/jQuery.print.min.js"></script>
<div id='fb-root'></div>
<script>
  window.addEventListener('scroll', () =>
    setTimeout(() => {
      (function(d, s, id) {
        var js, fjs = d.getElementsByTagName(s)[0];
        if (d.getElementById(id)) return;
        js = d.createElement(s); js.id = id;
        js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=122882951100578";
        fjs.parentNode.insertBefore(js, fjs);
      }(document, 'script', 'facebook-jssdk'));
    }, 1000),
    {once: true}
  );
</script>
<script>
  //= javascript_include_tag '//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-52a6071c0ad9d295', async: true
  window.addEventListener('scroll', () =>
    setTimeout(() => {
      var script = document.createElement('script');
      script.type = 'text/javascript';
      script.src = "//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-52a6071c0ad9d295";
      document.getElementsByTagName('head')[0].appendChild(script);
    }, 1000),
    {once: true}
  );
</script>
</body>
</html>
