<!DOCTYPE html>
<html lang='en'>
<head>
<title>Volunteerism growing in Taylorsville | Taylorsville Journal</title>
<meta charset='utf-8'>
<meta content='LocablePublisherNetwork.com' name='generator'>
<meta content='width=device-width, initial-scale=1' name='viewport'>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"cc2c1fbc9a","applicationID":"18721","transactionName":"IQwNRUJXWQhdEBdZRxYKAF1VSxoXUA1P","queueTime":3,"applicationTime":170,"agent":""}</script>
<script>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</script>
<meta content='122882951100578' property='fb:app_id'>
<meta property="og:title" content="Volunteerism growing in Taylorsville | Taylorsville Journal" /><meta name="description" content="With the new $39 million Mid-Valley Performing Arts Center scheduled to open next fall, Taylorsville Arts Council members are getting excited. They hope the new facility will increase volunteerism, a trend already being seen in the city. " /><meta property="og:description" content="With the new $39 million Mid-Valley Performing Arts Center scheduled to open next fall, Taylorsville Arts Council members are getting excited. They hope the new facility will increase volunteerism, a trend already being seen in the city. " /><meta name="keywords" content="Today, Local Life" /><meta name="ICMB" content="" /><link rel="canonical" href="https://www.taylorsvillecityjournal.com/2020/01/08/294436/volunteerism-growing-in-taylorsville" /><meta property="og:url" content="http://www.taylorsvillecityjournal.com/2020/01/08/294436/volunteerism-growing-in-taylorsville" /><meta content='article' property='og:type'>
<meta content='http://locable-assets-production.s3.amazonaws.com/uploads/resource/file/668390/Tville_20local_20life_202.JPG?timestamp=1578519715' property='og:image'>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="Mu3wagS3/+pdB6mf5iZjpbMMzoWHdiJD88HYNbFr/9FOtLAtr5cb3PkZj4LQDSipEqe7ezrVk26P2M+QZh4fiA==" />
<link rel="shortcut icon" type="image/x-icon" href="//cdn0.locable.com/uploads/favicon_img/file/42/CJ_Favicon-32x32.png" />
<link rel="stylesheet" media="screen" href="//cdn0.locable.com/assets/application-6f832c0e5f10e2488664ded0f7caf5eda1b0b44b87742db82a589c8e93c7dfe8.css" />
<link rel="stylesheet" media="print" href="//cdn3.locable.com/assets/print-a8ed28965cfc1e180c5fb2bf9a2246811c389e56a792ba2c42606d164408fef0.css" />
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
</script>
<script>
  ga('create', 'UA-62913511-1', 'auto');
  ga('send', 'pageview');
</script>
<script>
  ga('create', 'UA-16494411-5', 'auto', {'name': 'rollup'});
  ga('rollup.send', 'pageview');
</script>
<style>
  .custom-header, .custom-header a {color: #ffffff !important; }.custom-header {background-color: #1b4077 !important; }.custom-header {text-align: center !important; }#main-nav .navbar-nav .nav-link, .classic-nav .navbar-brand .navbar-text, #main-nav .navbar-toggler span {color:  !important;} #main-nav .navbar-toggler {border-color:  !important;}#main-nav .navbar-nav .nav-link:hover, .classic-nav .navbar-brand:hover .navbar-text {color: #cbb677 !important;}#main-nav .navbar-nav .nav-link:hover, .classic-nav .navbar-brand:hover .navbar-text {background-color: #1b4077 !important;}.public #main-nav .container, .dco #main-nav .container, .admin #main-nav, .admin #main-nav .container {background-color:  !important;}#main-nav .dropdown-item {color:  !important;}#main-nav .dropdown-item:hover {color:  !important;}#main-nav .dropdown-item:hover {background-color:  !important;}#main-nav .dropdown-menu {background-color:  !important;}#secondary-nav .navbar-nav .nav-link, #secondary-nav a {color: #ffffff !important;}#secondary-nav .navbar-nav .nav-link:hover, #secondary-nav a:hover {color: #1b4077 !important;}#secondary-nav .navbar-nav .nav-link:hover, #seconary-nav a:hover {background-color: #cbb677 !important;}#secondary-nav nav {background-color: #1b4077 !important;}#secondary-nav .navbar-nav .dropdown-menu .nav-link {color:  !important;}#secondary-nav .navbar-nav .dropdown-menu .nav-link:hover {color:  !important;}#secondary-nav .navbar-nav .dropdown-menu .nav-link:hover {background-color:  !important;}#secondary-nav .dropdown-menu {background-color:  !important;}#secondary-nav .navbar-nav .nav-link, #secondary-nav a {font-size: 1.2rem !important; line-height: 1.2rem; letter-spacing: 1.5px;}.col-menu li a, .simple-footer li a, #copyright p.text-muted a {color:  !important; }.col-menu li a:hover, .simple-footer li a:hover, #copyright p.text-muted a:hover {color: #1b4077 !important; }#footer p, #footer h6, #copyright p {color:  !important; }.places #copyright, .places #footer, #copyright .container, #footer .container {background-color:  !important; }
</style>
<style>
  
</style>
<meta name="google-site-verification" content="qzXgywgOkaMgeBvUTT0hJx0Wtq3ZLucK8uFD7fTB8q4" />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-6933468165322014",
    enable_page_level_ads: true
  });
</script>
<script async='' defer='defer' src='https://addevent.com/libs/atc/1.6.1/atc.min.js' type='text/javascript'></script>
</head>
<body class='classic-header public'>
<a class="sr-only" href="#content">Skip to main content</a>
<div class='fixed-top' data-toggle='affix'>
<section id='main-nav'>
<div class='container theme-shadow bg-white'>
<nav class='classic-nav navbar navbar-expand-lg navbar-light'>
<a class="navbar-brand" href="/"><span class='navbar-text fas fa-home' style='position:relative;top:2px'></span>
</a><button aria-controls='navbarContent' aria-expanded='false' aria-label='Toggle navigation' class='navbar-toggler' data-target='#navbarContent' data-toggle='collapse' type='button'>
<span class='fas fa-bars'></span>
</button>
<div class='collapse navbar-collapse' id='navbarContent'>
<ul class='navbar-nav mr-lg-auto' style='white-space: nowrap;'>
<li class='nav-item page-60526-nav'><a class="nav-link" href="/pages/aboutus">About Us</a></li>

<li class='nav-item page-60534-nav'><a class="nav-link" href="/pages/advertise">Advertise</a></li>

<li class='nav-item page-52022-nav'><a class="nav-link" href="/pages/digitalissues">E-Edition</a></li>

<li class='nav-item page-92572-nav'><a class="nav-link" href="/pages/rack-locations">Rack Locations</a></li>

<li class='nav-item page-114341-nav'><a class="nav-link" href="/pages/more-journals">More Journals</a></li>

<li class='nav-item page-60548-nav'><a class="nav-link" href="/pages/contactus">Contact Us</a></li>

<div class='dropdown-divider d-inline d-lg-none'></div>
<div class='d-lg-none'>
<li class='category-134-nav nav-item theme-menu-toggle' data-toggle='category-134'>

<a class="nav-link" href="/categories/news">News
<b class='caret'></b>
</a></li>
<li class='category-425-nav nav-item theme-menu-toggle' data-toggle='category-425'>

<a class="nav-link" href="/categories/sports">Sports
<b class='caret'></b>
</a></li>
<li class='category-636-nav nav-item theme-menu-toggle' data-toggle='category-636'>

<a class="nav-link" href="/categories/local-life">Local Life
<b class='caret'></b>
</a></li>
<li class='category-423-nav nav-item theme-menu-toggle' data-toggle='category-423'>

<a class="nav-link" href="/categories/education">Education
<b class='caret'></b>
</a></li>
<li class='category-776-nav nav-item theme-menu-toggle' data-toggle='category-776'>

<a class="nav-link" href="/categories/business">Business
<b class='caret'></b>
</a></li>
<li class='category-104-nav nav-item theme-menu-toggle' data-toggle='category-104'>

<a class="nav-link" href="/categories/food-dining">Food+Dining
<b class='caret'></b>
</a></li>
<li class='category-101-nav nav-item theme-menu-toggle' data-toggle='category-101'>

<a class="nav-link" href="/categories/arts-entertainment">Arts+Entertainment
<b class='caret'></b>
</a></li>
<li class='calendar-nav nav-item theme-menu-toggle' data-toggle='calendar'>

<a class="nav-link" href="/calendar">Calendar
<b class='caret'></b>
</a></li>
<li class='directory-nav nav-item theme-menu-toggle' data-toggle='directory'>

<a class="nav-link" href="/businesses">Directory
<b class='caret'></b>
</a></li>
<div class='dropdown-divider d-inline d-lg-none'></div>
<div class='dropdown-divider'></div>
</div>
<div class='d-lg-none'>

<li class='nav-item'><a class="nav-link px--lg-2 py-lg-0 submit-event-link" href="/events/new">Submit an Event</a></li>
<li class='nav-item'><a class="nav-link px-lg-2 py-lg-0 create-listing-link" href="/places">List Your Business</a></li>
<li class='nav-item'>
<a class="nav-link px-lg-2 py-lg-0" href="/users/sign_in">Login/Join
</a></li>
<div class='dropdown-divider'></div>
</div>
</ul>
<ul class='navbar-nav ml-lg-auto'>
<ul class='list-inline social-links' style='white-space: nowrap;'>
<li class='list-inline-item mr-2'>
<a target="_blank" class="facebook" href="https://www.facebook.com/TKJournal/"><i class='fab fa-facebook fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="instagram" href="https://instagram.com/cityjournals"><i class='fab fa-instagram fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="linkedin" href="https://www.linkedin.com/company/city-journals/"><i class='fab fa-linkedin fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="twitter" href="https://twitter.com/TVilleJournal"><i class='fab fa-twitter fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="email" href="/pages/contactus"><i class='fas fa-envelope fa-2x'></i>
</a></li>
</ul>
<form class="form-inline" action="/search" accept-charset="UTF-8" method="get"><input name="utf8" type="hidden" value="&#x2713;" />
<div class='input-group'>
<label class="sr-only" for="q">Search</label>
<input type="text" name="q" id="q" placeholder="Search Site" class="form-control" />
<span class='input-group-btn'>
<button class='btn btn-secondary btn-search'>
<span class='sr-only'>Search</span>
<span class='fas fa-search'></span>
</button>
</span>
</div>
</form>
</ul>
</div>
</nav>
</div>
</section>
</div>
<section id='alerts'>
<div class='container theme-shadow bg-white'>
<div class='d-flex justify-content-center'>
</div>
</div>
</section>
<header>
<section id='masthead'>
<div class='container theme-shadow bg-white'>
<div class='row'>
<div class='col-12 col-md-5'>
<h1 class='p-3'><a href="/"><img alt="Taylorsville Journal" style="max-width: 100%;" src="//cdn3.locable.com/uploads/logo_image/file/407/CJ-Website_Taylorsville.png" /></a></h1>
</div>
<div class='col-12 col-md-7'>
<div class='py-3'>
<script type="text/javascript">
    var _ss = _ss || [];
    _ss.push(['_setDomain', 'https://koi-3QNIUMYMX0.marketingautomation.services/net']);
    _ss.push(['_setAccount', 'KOI-441KJ55HUQ']);
    _ss.push(['_trackPageView']);
(function() {
    var ss = document.createElement('script');
    ss.type = 'text/javascript'; ss.async = true;
    ss.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'koi-3QNIUMYMX0.marketingautomation.services/client/ss.js?ver=1.1.1';
    var scr = document.getElementsByTagName('script')[0];
    scr.parentNode.insertBefore(ss, scr);
})();
</script></div>
</div>
</div>
</div>
</section>
<div class='d-none d-lg-inline'>
<section id='secondary-nav'>
<div class='container theme-shadow bg-white'>
<div class='row py-1'>
<div class='col-sm-12'>
<nav class='navbar navbar-expand-lg navbar-light'>

<ul class='navbar-nav mr-auto flex-wrap' style='white-space: nowrap;'>






<li class='category-134-nav nav-item theme-menu-toggle' data-toggle='category-134'>

<a class="nav-link" href="/categories/news">News
<b class='caret'></b>
</a></li>
<li class='category-425-nav nav-item theme-menu-toggle' data-toggle='category-425'>

<a class="nav-link" href="/categories/sports">Sports
<b class='caret'></b>
</a></li>
<li class='category-636-nav nav-item theme-menu-toggle' data-toggle='category-636'>

<a class="nav-link" href="/categories/local-life">Local Life
<b class='caret'></b>
</a></li>
<li class='category-423-nav nav-item theme-menu-toggle' data-toggle='category-423'>

<a class="nav-link" href="/categories/education">Education
<b class='caret'></b>
</a></li>
<li class='category-776-nav nav-item theme-menu-toggle' data-toggle='category-776'>

<a class="nav-link" href="/categories/business">Business
<b class='caret'></b>
</a></li>
<li class='category-104-nav nav-item theme-menu-toggle' data-toggle='category-104'>

<a class="nav-link" href="/categories/food-dining">Food+Dining
<b class='caret'></b>
</a></li>
<li class='category-101-nav nav-item theme-menu-toggle' data-toggle='category-101'>

<a class="nav-link" href="/categories/arts-entertainment">Arts+Entertainment
<b class='caret'></b>
</a></li>
<li class='calendar-nav nav-item theme-menu-toggle' data-toggle='calendar'>

<a class="nav-link" href="/calendar">Calendar
<b class='caret'></b>
</a></li>
<li class='directory-nav nav-item theme-menu-toggle' data-toggle='directory'>

<a class="nav-link" href="/businesses">Directory
<b class='caret'></b>
</a></li>
<div class='dropdown-divider d-inline d-lg-none'></div>
</ul>
</nav>
</div>
</div>
</div>
</section>
</div>
<section id='pushdown'>
<div class='container theme-shadow bg-white'>
<div class='d-flex justify-content-center'>
<div class='py-3'><broadstreet-zone zone-id='pushdown' keywords='articles, article_volunteerism-growing-in-taylorsville, taylorsville-journal'></broadstreet-zone><broadstreet-zone alt-zone-id='pushdown' keywords='articles, article_volunteerism-growing-in-taylorsville, taylorsville-journal' , count='1'></broadstreet-zone></div>
</div>
</div>
</section>
</header>
<div class='container theme-shadow bg-white' id='content'>
<div class='row'>
<div class='col-12 col-lg-8'>
<section id='admin-buttons'>
<div class='container'>
<div class='row'>
<div class='col-12'>
<div class='btn-group btn-group-sm'>
</div>
</div>
</div>
<div class='row py-2'>
<div class='col-12'>
</div>
</div>
</div>
</section>
<article>
<div class='container'>
<div class=''>
<div class='row py-3'>
<div class='col-12'>
<h1 class='py-0'>
<div class='text-capitalize'>Volunteerism growing in Taylorsville</div>
</h1>
<span class='small text-muted'>
Jan 08, 2020 02:42PM
&#x25CF By Carl Fauver
</span>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='images-contain'>
<img alt="" class="img-fluid" src="//cdn3.locable.com/uploads/resource/file/668390/fill/800x600/Tville_20local_20life_202.JPG?timestamp=1578519715" />
</div>
<p class='h6 text-right'>
<strong>Mitchel Harker (right of the little library) poses with his parents, two brothers and his fellow BSA Troop 1069 members, before presenting his handmade Eagle Scout service project to the Taylorsville City Council. (Carl Fauver/City Journals) </strong>
</p>
</div>
</div>
<div class='d-flex justify-content-center'>
<div class='py-3 broadstreet'>
<broadstreet-zone zone-id='sponsored' keywords='articles, article_volunteerism-growing-in-taylorsville, taylorsville-journal'></broadstreet-zone><broadstreet-zone alt-zone-id='sponsored' keywords='articles, article_volunteerism-growing-in-taylorsville, taylorsville-journal' , count='1'></broadstreet-zone>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='clearfix images-contain images-thumbnails'>
<p><span>By Carl Fauver | <a href="/cdn-cgi/l/email-protection#4e2d2f3c22280e23372d273a3724213b3c202f223d602d2123"><span class="__cf_email__" data-cfemail="caa9abb8a6ac8aa7b3a9a3beb3a0a5bfb8a4aba6b9e4a9a5a7">[email&#160;protected]</span></a></span> </p>
<p>When confronted by an issue from a Taylorsville resident, it’s not uncommon to hear Mayor Kristie Overson say something like, “I agree that’s something we need to address. Would you be willing to volunteer to help us solve the problem?”</p>
<p>The mayor is not alone. City council members also constantly seeking more volunteers for the various service committees they oversee.</p>
<p>In 2019, city residents began to step up in a big way. Memberships have grown in several of the city’s volunteer committees, particularly the Parks &amp; Recreation, Cultural Diversity and Historic Preservation committees.</p>
<p>“Our Parks &amp; Recreation Committee grew from two active members to six in 2019,” Councilwoman Meredith Harker said. “I think a big part of it is because we are working hard to communicate better with people, especially through social media. We are getting the word out about things. People naturally become more active — and volunteer more of their time — when they are aware of what is happening.”</p>
<p>“We’ve seen more volunteers in our bigger events,” Overson said. “It’s great to see because nearly all of our city activities need volunteers to make them successful.”</p>
<p>In addition to improved communication, another unusual factor played into a volunteerism boost in 2019. And yet another unique circumstance is expected to do the same in 2020.</p>
<p>Let’s look back, and forward, at each of those.</p>
<p><b>Boy Scout Eagle service projects</b></p>
<p>It was well-publicized for at least a year, The Church of Jesus Christ of Latter-day Saints planned to sever its 105-year affiliation with the Boy Scouts of America. Recent turmoil within the BSA prompted the faith to overhaul its youth development programs for both boys and girls.</p>
<p>As the clock wound down in 2019, many Utah Boy Scouts went into overdrive to try to earn the BSA’s top rank, the Eagle, before their church troops were disbanded.</p>
<p>This proved to be good news for Taylorsville, in a couple of areas, particularly at the Taylorsville Bennion Heritage Center (1488 West 4800 South) where several Eagle Scout candidates, troopmates, relatives and friends assisted in the completion of beat-the-clock service projects. </p>
<p>“When Eagle Scout candidates take on projects at the heritage center, it saves our own maintenance crews time and money,” Overson said. “More importantly, it has been a great tradition. The museum had a great relationship with the Boy Scouts for many years.”</p>
<p>Two of the final Taylorsville Boy Scouts to finish up Eagle service projects at the heritage center were Eisenhower Junior High eighth grader Andrew Valora and Cottonwood High School Senior Kyle Jones.</p>
<p>“For my project, we stained and painted several things [at the heritage center], including a couple of buildings, an outhouse, two benches and a cider press,” Valora said. “I took a field trip here a few years ago. I chose this project because it helps the local community.”</p>
<p>A member of Taylorsville North Stake Troop 948, Andrew was the third Valora boy to earn the Eagle Scout rank. </p>
<p>Meantime, from the Jordan Stake Third Ward Troop 636, Jones and his younger brother were also racing to complete their Eagle Scout projects before the end of 2019. Their three older brothers had already earned the rank. Kyle led the restoration of an antique piece of equipment at the heritage center, believed to be well over 100 years old.</p>
<p>“We had suggested a scout restore our ice hauling sled as a service project to several Eagle candidates, but Kyle was the first one willing to do it,” said Taylorsville Historic Preservation Committee Chairwoman Susan Yadeskie. “We believe the sleigh dates back to between 1900 and 1910. He did such a great job.”</p>
<p>Meanwhile, another Boy Scout scrambling to finish his Eagle Service project assisted the city in a different area.</p>
<p>Mitchel Harker, 18, son of Councilwoman Meredith Harker, chose to complete a lasting Eagle service project by constructing a little library. </p>
<p>“As a teacher, I am a big supporter of reading, for children and adults,” Meredith Harker said. “But not everyone can get to the Taylorsville Library when they want to. I’m excited to see people get access to books in another way. I hope Mitchel’s project will encourage others to build little libraries for our city.”</p>
<p>“Little libraries” are fairly small weatherproof boxes with doors on the front and shelves to hold 30 to 40 books. Popular in many parts of the country — but, so far, not so much in Utah — the boxes are receptacles for putting unwanted books in, or pulling a book out, to read and return.</p>
<p>Mitchel’s little library is about 2 feet tall and wide by 15 inches deep. His Eagle Scout project donation to Taylorsville City included 35 books, completely filling it.</p>
<p>Last October, the little library was installed at Bennion Park (3200 West 5620 South). Its unveiling was part of a joint ceremony, as the city also planted two maple trees there after young Tanner Cowley, 9, raised more than $725 to purchase them. City officials matched his donation, and a crowd looked on as the trees went into the ground and Harker’s little library went into service.</p>
<p>With 2019 now behind us, Boy Scout Eagle service projects are expected to largely become a thing of the past in Taylorsville.</p>
<p>However, the new decade is expected to boost volunteerism in a completely different area.</p>
<p><b>Mid-Valley Performing Arts Center to open</b></p>
<p>“This is, by far, the most momentous thing the arts council has ever been a part of,” Taylorsville Arts Council Co-Chairman Howard Wilson said in describing the anticipated opening this fall of the $39 million Mid-Valley Performing Arts Center, southeast of city hall. “I joined the arts council in 2000, and we have been looking for a good, affordable performing venue ever since then.”</p>
<p>Now that it is coming on line — with the first shows tentatively planned for next December — arts council volunteers expect their ranks to grow.</p>
<p>“We are always looking for new members, more volunteers,” arts council Treasurer Gordon Wolf said. “Hopefully, once the doors are open on the new center, it will become a magnet to involve more people.”</p>
<p>It’s been more than three years now since Salt Lake County leaders unveiled their plans to construct the Mid-Valley Performing Arts Center in Taylorsville. The city was chosen over Murray and other competing cities, thanks in large part to the Taylorsville City Council voting to donate the land for construction.</p>
<p>Following two years of planning and design work, ground was finally broken on the center just over a year ago. Last summer, Salt Lake County officials announced, barring unforeseen building delays, the arts center should be “essentially” finished by Oct. 1, 2020. Their plan is to then spend two months testing all of the facility’s new equipment.  </p>
<p>“It will be really nice to have a wonderful new venue,” Taylorsville Arts Council Co-Chair Susan Holman said. “We’ve already seen more people volunteering at our activities, because the new center is coming. And we expect that to grow this year, as more people become aware of it.”</p>
<p>In addition to having the new venue right in their proverbial backyard, the Taylorsville Arts Council will also enjoy some additional benefits. For starters, as part of its negotiated agreement with Salt Lake County, Taylorsville is receiving 16 rent-free nights each year, to make use of the arts center. The local arts council will also enjoy permanent rent-free storage in the new facility.</p>
<p>“Right now, the arts council spends $100 per month for a storage unit out by Airport 2,” Wolf said. “But we’ve been told, the new arts center will include a 10-by-10-square-foot storage area just for us that we can lock. Additionally, during the run of our productions, [county officials] have said additional temporary storage areas will be available for our props.”</p>
<p>In anticipation of the Mid-Valley Performing Arts Center opening, Taylorsville City Council members also boosted their annual arts council budget from $10,000 to $15,000.</p>
<p>“The city has never said ‘no’ to one of our budget requests,” Wolf said. “We have been realistic about our financial requests, and they have never turned us down. The additional annual funding will help us make even better use of the arts center.”</p>
<p>Perhaps no one is more excited about the new arts center opening than Taylorsville Arts Council Director of Musicals Wendy Smedshammer.</p>
<p>“My heart gets aflutter thinking about all the magic we get to create in there,” she said. “One thing we are super excited about is we can now leave our sets and props out overnight and not risk vandalism. We can’t do that at the outdoor [Salt Lake Community College] amphitheater. It is our hope to do more shows once the arts center opens.”</p>
<p>Salt Lake County leaders have promised the Taylorsville Arts Council it can host the first major show in the new arts center. The local group plans to stage “Joseph and the Amazing Technicolor Dreamcoat” as its first production there.</p>
<p>“We last did ‘Joseph’ about five years ago at the SLCC amphitheater, and it was a crowd favorite,” Smedshammer said.</p>
<p>Finally, in addition to all the stage productions the Mid-Valley Performing Arts Center will host, the new facility will become the venue for the annual Taylorsville Art Show, now being held at the city’s senior center. Also, art show winners will remain on display in the arts center for the succeeding year.</p>
<p>“We really don’t know exactly how the new arts center will impact the Taylorsville Arts Council, but we look forward to learning,” Wilson said. “We know things should be bigger and better. And along with that, we’ll need more volunteers. I am confident they will come.”</p>
</div>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='addthis_native_toolbox'></div>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<span class='fas fa-tags' style='margin-right: 2px'></span>
<a style="color: #555" href="/categories/today">Today</a>, <a style="color: #555" href="/categories/local-life">Local Life</a>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
Follow the Taylorsville Journal on Facebook!
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='fb-comments' data-href='http://www.taylorsvillecityjournal.com/2020/01/08/294436/volunteerism-growing-in-taylorsville' data-width='100%'></div>
</div>
</div>
</div>
</div>
</article>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
  var addthis_share = {
     url: "https://www.taylorsvillecityjournal.com/2020/01/08/294436/volunteerism-growing-in-taylorsville",
     title: "Volunteerism growing in Taylorsville",
     description: "With the new $39 million Mid-Valley Performing Arts Center scheduled to open next fall, Taylorsville Arts Council members are getting excited. They hope the new facility will increase volunteerism, a trend already being seen in the city.",
     media: "//cdn1.locable.com/uploads/resource/file/668390/fill/1200x600/Tville_20local_20life_202.JPG?timestamp=1578519715"
  }
</script>
</div>
<div class='col-12 col-lg-4'>
<div class='div' style='width: 300px; margin: auto;'>
<div class='undecorate'>
<div class='my-3'>
<h5 class='px-3 py-2 custom-header'>Upcoming Events Near You</h5>
</div>
</div>
<div id='calendar-widget'>
<div class='undecorate'>
<div class='my-3'>
<a class="undecorate" href="/events/179349/lets-do-lunch-slackwater-pub-pizzeria"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
8
</strong>
</div>
<div class='media-body ml-2'>
<h6>Let's Do Lunch: Slackwater Pub &amp; Pizzeria</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
11:30am
&#183;
Slackwater Sandy
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/174643/magic-monday"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
13
</strong>
</div>
<div class='media-body ml-2'>
<h6>Magic Monday</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
7:00pm
&#183;
Hatch Family Chocolates
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/180503/getting-started-with-creative-writing"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
14
</strong>
</div>
<div class='media-body ml-2'>
<h6>Getting Started With Creative Writing</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
6:00pm
&#183;
SLCC Community Writing Center
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/174643/magic-monday"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
20
</strong>
</div>
<div class='media-body ml-2'>
<h6>Magic Monday</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
7:00pm
&#183;
Hatch Family Chocolates
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/180503/getting-started-with-creative-writing"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
21
</strong>
</div>
<div class='media-body ml-2'>
<h6>Getting Started With Creative Writing</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
6:00pm
&#183;
SLCC Community Writing Center
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/174695/parlor-magic"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
26
</strong>
</div>
<div class='media-body ml-2'>
<h6>Parlor Magic</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
5:00pm
&#183;
Prohibition
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/174697/magic-show-circus-of-the-strange"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
26
</strong>
</div>
<div class='media-body ml-2'>
<h6>Magic Show: Circus of the Strange</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
7:00pm
&#183;
Urban Arts Gallery
</div>
</div>
</div>
</div>
</div>
</div>
</a>
<div class='d-flex justify-content-center pb-3'>
<a class="btn btn-light" href="/calendar"><div class='fas fa-calendar-alt'></div>
View All
</a><a class="btn btn-light rounded-0" href="/events/new"><div class='fas fa-plus-circle'></div>
Add Your Event
</a></div>
</div>
</div>
</div>
<div class='images-sidebar my-3 clearfix'>
<div class="image-medium"><a href="https://visitor.r20.constantcontact.com/manage/optin?v=001iTDOE5WqIXkxQh0KtiP6H6B8BbHB4qfswqRgBcay-kHf68Em8lT99NPkA3atW6HRv683TfG2Ys8qhoXT0iulSps1bFNLzqU5AyttHKkL5Ac="><img alt="" src="//cdn3.locable.com/uploads/resource/file/514841/fill/300x0/Newsletter_20Sign_20Up.jpg?timestamp=1551725871"></a></div>
</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>Online Edition</h5>
<iframe allowfullscreen allow="fullscreen" style="border:none;width:100%;height:350px;" src="//e.issuu.com/embed.html?d=taylorsville_dec_web&u=mycityjournals"></iframe>
</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>Follow The City Journals on Facebook</h5>
<div class="fb-page" data-href="https://www.facebook.com/The-City-Journals-1508669356040840/" data-tabs="timeline" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/The-City-Journals-1508669356040840/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/The-City-Journals-1508669356040840/">The City Journals</a></blockquote></div>
</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>Follow The City Journals on Twitter</h5>
<a class="twitter-timeline" data-width="300" data-height="275" href="https://twitter.com/MyCityJournals?ref_src=twsrc%5Etfw">Tweets by MyCityJournals</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>Follow The City Journals on LinkedIn</h5>
<div align="center" width="300" height="200"><script src="https://platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
<script type="IN/FollowCompany" data-id="18895884" data-counter="top"></script></div>
</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>Advertise With Us</h5>
<div class="image-medium"><a href="http://www.taylorsvillejournal.com/pages/advertise"><img alt="" src="//cdn0.locable.com/uploads/resource/file/514872/fill/300x0/CityJournals-_300x250__AWU-Sidebar.jpg?timestamp=1551737145"></a></div>
</div>
</div>
</div>
</div>
</div>
<footer>
<section id='community-sponsor-footer'>
<div class='container theme-shadow bg-white'>
<div class='row py-3'>
<div class='col-sm-12'>
</div>
</div>
</div>
</section>
<section id='footer-embed'>
<div class='container theme-shadow bg-white'>
<div class='row py-3'>
<div class='col-sm-12'>
</div>
</div>
</div>
</section>
<section id='footer'>
<div class='container theme-shadow bg-white'>
<div class='row py-3'>
<div class='col-sm-3'>
<div class='mx-2'>
<h6 class='text-uppercase'>Categories</h6>
<ul class='list-unstyled col-menu'>
<li>
<a href="/categories/arts-entertainment"><i class='fas fa-angle-double-right'></i>
Arts+Entertainment
</a></li>
<li>
<a href="/categories/business"><i class='fas fa-angle-double-right'></i>
Business
</a></li>
<li>
<a href="/categories/education"><i class='fas fa-angle-double-right'></i>
Education
</a></li>
<li>
<a href="/categories/food-dining"><i class='fas fa-angle-double-right'></i>
Food+Dining
</a></li>
<li>
<a href="/categories/local-life"><i class='fas fa-angle-double-right'></i>
Local Life
</a></li>
<li>
<a href="/categories/news"><i class='fas fa-angle-double-right'></i>
News
</a></li>
<li>
<a href="/categories/sports"><i class='fas fa-angle-double-right'></i>
Sports
</a></li>
</ul>
</div>
</div>
<div class='col-sm-3'>
<div class='mx-2'>
<h6 class='text-uppercase'>About Us</h6>
<ul class='list-unstyled col-menu'>

<li>
<a href="/pages/rack-locations"><i class='fas fa-angle-double-right'></i>
Rack Locations
</a></li>
<li>
<a href="/pages/more-journals"><i class='fas fa-angle-double-right'></i>
More Journals
</a></li>
<li>
<a href="/pages/advertise"><i class='fas fa-angle-double-right'></i>
Advertise
</a></li>
<li>
<a href="/pages/delivery-request"><i class='fas fa-angle-double-right'></i>
Delivery Request
</a></li>
<li>
<a href="/pages/aboutus"><i class='fas fa-angle-double-right'></i>
About Us
</a></li>
<li>
<a href="/pages/digitalissues"><i class='fas fa-angle-double-right'></i>
E-Edition
</a></li>
</ul>
</div>
</div>
<div class='col-sm-4 offset-sm-2'>
<h1><a href="/"><img alt="Taylorsville Journal" class="img-fluid" src="//cdn2.locable.com/uploads/logo_image/file/407/CJ-Website_Taylorsville.png" /></a></h1>
<p class='p-0 m-0'>9500 South 500 West - Suite 205</p>
<p class='p-0 m-0'>Sandy, UT 84070</p>
<p class='p-0 m-0'>(801) 254-5974</p>
<nav class='navbar navbar-expand-lg pull-left'>
<ul class='list-inline social-links' style='white-space: nowrap;'>
<li class='list-inline-item mr-2'>
<a target="_blank" class="facebook" href="https://www.facebook.com/TKJournal/"><i class='fab fa-facebook fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="instagram" href="https://instagram.com/cityjournals"><i class='fab fa-instagram fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="linkedin" href="https://www.linkedin.com/company/city-journals/"><i class='fab fa-linkedin fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="twitter" href="https://twitter.com/TVilleJournal"><i class='fab fa-twitter fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="email" href="/pages/contactus"><i class='fas fa-envelope fa-2x'></i>
</a></li>
</ul>
</nav>
</div>
</div>
</div>
</section>
<section id='copyright'>
<div class='container theme-shadow'>
<div class='row pt-3' style='padding-bottom: 50px;'>
<div class='col-12'>
<p class='text-muted small p-0 m-0'>
<span class='far fa-copyright'></span>
2020 | Powered by <a target="_blank" class="text-muted" href="//www.locable.com">Locable</a>
|
<a class="text-muted" href="//national.locable.com/pages/terms-of-use">Terms of Service</a>
</p>
</div>
</div>
</div>
</section>
<section class='fixed-bottom' id='admin-bar'>
<nav>
<div class='d-none d-lg-flex'>
<div class='container'>
<ul class='nav justify-content-center px-3 mx-auto'>

<li class='nav-item'><a class="nav-link px--lg-2 py-lg-0 submit-event-link" href="/events/new">Submit an Event</a></li>
<li class='nav-item'><a class="nav-link px-lg-2 py-lg-0 create-listing-link" href="/places">List Your Business</a></li>
<li class='nav-item'>
<a class="nav-link px-lg-2 py-lg-0" href="/users/sign_in">Login/Join
</a></li>
</ul>
</div>
</div>
</nav>
</section>
</footer>
<div class='modal fade' id='welcome-modal' role='dialog' tabindex='-1'>
<div class='modal-dialog modal-lg' role='document'>
<div class='modal-content'></div>
</div>
</div>
<broadstreet-zone zone-id='popout' keywords='articles, article_volunteerism-growing-in-taylorsville, taylorsville-journal'></broadstreet-zone><broadstreet-zone alt-zone-id='popout' keywords='articles, article_volunteerism-growing-in-taylorsville, taylorsville-journal' , count='1'></broadstreet-zone>
<script src="//cdn3.locable.com/assets/application-5afc31e2a381c16d1371865dfe55da7631adf2b6f9f795c7b580c1b335e78d15.js"></script>
<div id='fb-root'></div>
<script>
  (function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=122882951100578";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));
</script>
<script>
  window.s3DirectPostUrl = "https://locable-processing.s3.amazonaws.com/";
  window.s3DirectPostFields = {"AWSAccessKeyId":"AKIAJ6MRUF66HJSZBEVA","key":"uploads/058eda8d-3aa3-4072-8ed6-0f53a78e0708/${filename}","policy":"eyJleHBpcmF0aW9uIjoiMjAyMC0wMS0wOFQyMjo1OTo0MVoiLCJjb25kaXRpb25zIjpbeyJidWNrZXQiOiJsb2NhYmxlLXByb2Nlc3NpbmcifSxbInN0YXJ0cy13aXRoIiwiJGtleSIsInVwbG9hZHMvMDU4ZWRhOGQtM2FhMy00MDcyLThlZDYtMGY1M2E3OGUwNzA4LyJdLHsic3VjY2Vzc19hY3Rpb25fc3RhdHVzIjoiMjAxIn0seyJhY2wiOiJwdWJsaWMtcmVhZCJ9XX0=","signature":"FJviy2RjMAD+XDKMcawV3sQgMZ0=","success_action_status":"201","acl":"public-read"};
</script>
<script src="https://static.locablepublishernetwork.com/init-2.min.js" async="async"></script>
<script>
  window.broadstreet = window.broadstreet || { run: [] };
  window.broadstreet.run.push(function() {
    broadstreet.watch( {
      "autoAttach": {},
      "autoAttachAndWatch": {},
      "keywords": ["articles", "article_volunteerism-growing-in-taylorsville", "taylorsville-journal"],
      "networkId": "2402",
      "selector": 'broadstreet-zone',
      "softKeywords": true,
      "uriKeywords": false,
      "useZoneAliases": true,
      "useAltZone": 768,
      "domain": "sponsors.locablepublishernetwork.com"
    });
  });
</script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/jQuery.print/1.5.1/jQuery.print.min.js"></script>
<script src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-52a6071c0ad9d295" async="async"></script>
<script src='https://code.jquery.com/jquery-migrate-3.0.1.js' type='text/javascript'></script>
</body>
</html>
